Skip to content

← Actionable
High, CVSS 7.4

Starship vulnerable to shell injection via undocumented, unpredictable shell expansion in custom commands

CVE-2024-41815GHSA-vx24-x4mv-vwr5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (starship 1.20.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io starship

    Affected
    >= 1.0.0, <= 1.19.0
    Fixed in
    1.20.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-41815: 0.46% estimated exploitation activity in the next 30 days; percentile 40.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Starship is a cross-shell prompt. Starting in version 1.0.0 and prior to version 1.20.0, undocumented and unpredictable shell expansion and/or quoting rules make it easily to accidentally cause shell injection when using custom commands with starship in bash. Version 1.20.0 fixes the vulnerability. PoC Have some custom command which prints out information from a potentially untrusted/unverified source. Impact This issue only affects users with custom commands, so the scope is limited, and without knowledge of others' commands, it could be hard to successfully target someone.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vx24-x4mv-vwr5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-41815

Advisory: Starship vulnerable to shell injection via undocumented, unpredictable shell expansion in custom commands
IDs: CVE-2024-41815, GHSA-vx24-x4mv-vwr5
Record: https://patchnext.com/advisories/cve-2024-41815 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: starship 1.20.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io starship: affected >= 1.0.0, <= 1.19.0; fixed in 1.20.0

## Suggested inspection (read-only)
- crates.io starship: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on starship.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vx24-x4mv-vwr5 (GitHub-reviewed advisory GHSA-vx24-x4mv-vwr5 lists affected ranges: crates.io starship >=1.0.0 <=1.19.0)

Commands are suggestions: review each one before running it.

Loading voting…