Skip to content

← Public intelligence

crates.io package

serde-json-wasm

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5crates.ioPublished

    serde-json-wasm stack overflow during recursive JSON parsing

    CVE-2024-58264 · GHSA-rr69-rxr6-8qwf

    Affected
    • crates.io serde-json-wasm >= 1.0.0, <= 1.0.0; < 0.5.2
    Fixed in
    0.5.21.0.1· Vendor fix available
    Issue
    When parsing untrusted, deeply nested JSON, the stack may overflow, possibly enabling a Denial of Service attack. This was fixed by adding a check for recursion depth.

    Recommended action: Upgrade to 1.0.1 or 0.5.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →