Skip to content

← Actionable
High, CVSS 7.5

serde-json-wasm stack overflow during recursive JSON parsing

CVE-2024-58264GHSA-rr69-rxr6-8qwf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (serde-json-wasm 1.0.1, 0.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io serde-json-wasm

    Affected
    >= 1.0.0, <= 1.0.0< 0.5.2
    Fixed in
    0.5.2, 1.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2024-58264: 0.55% estimated exploitation activity in the next 30 days; percentile 45.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

When parsing untrusted, deeply nested JSON, the stack may overflow, possibly enabling a Denial of Service attack. This was fixed by adding a check for recursion depth.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rr69-rxr6-8qwf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-58264

Advisory: serde-json-wasm stack overflow during recursive JSON parsing
IDs: CVE-2024-58264, GHSA-rr69-rxr6-8qwf
Record: https://patchnext.com/advisories/cve-2024-58264 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: serde-json-wasm 1.0.1, 0.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io serde-json-wasm: affected >= 1.0.0, <= 1.0.0; < 0.5.2; fixed in 0.5.2, 1.0.1

## Suggested inspection (read-only)
- crates.io serde-json-wasm: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on serde-json-wasm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rr69-rxr6-8qwf (GitHub-reviewed advisory GHSA-rr69-rxr6-8qwf lists affected ranges: crates.io serde-json-wasm >=1.0.0 =0 <0.5.2)

Commands are suggestions: review each one before running it.

Loading voting…