Skip to content

← Public intelligence

crates.io package

postgres-protocol

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9crates.ioAmendedPublished

    postgres-protocol: Panic decoding a malformed hstore value allows denial of service

    GHSA-rgqc-3x5p-6gwg

    Affected
    • crates.io postgres-protocol < 0.6.12
    Fixed in
    0.6.12· Vendor fix available
    Issue
    A malicious or compromised server can return a binary hstore value with an invalid internal length field, causing the client to panic while decoding it. Applications that connect only to a trusted database are not exposed; the risk applies to clients that may connect to untrusted or user-supplied servers, or whose connection can be intercepted by a man-in-the-middle.

    Recommended action: Upgrade to 0.6.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.7crates.ioAmendedPublished

    postgres-protocol: Unbounded SCRAM iteration count allows a malicious server to cause CPU-exhaustion denial of service

    GHSA-5x78-73v4-xg6w

    Affected
    • crates.io postgres-protocol >= 0.3.0, < 0.6.12
    Fixed in
    0.6.12· Vendor fix available
    Issue
    A malicious, compromised, or man-in-the-middle server can supply an arbitrarily large SCRAM-SHA-256 PBKDF2 iteration count during authentication. The client runs it inline with no upper bound, pinning a tokio worker thread for minutes per connection, possibly stalling the whole async runtime. Applications that connect only to a trusted database are not exposed; the risk applies to clients that may connect to untrusted or user-supplied servers, or whose connection can be intercepted by a man-in-the-middle.

    Recommended action: Upgrade to 0.6.12 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →