postgres-protocol: Panic decoding a malformed hstore value allows denial of service
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (postgres-protocol 0.6.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io postgres-protocol
- Affected
- < 0.6.12
- Fixed in
- 0.6.12
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rgqc-3x5p-6gwg lists affected ranges: crates.io postgres-protocol >=0 <0.6.12 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rgqc-3x5p-6gwg lists affected ranges: crates.io postgres-protocol >=0 <0.6.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A malicious or compromised server can return a binary hstore value with an invalid internal length field, causing the client to panic while decoding it. Applications that connect only to a trusted database are not exposed; the risk applies to clients that may connect to untrusted or user-supplied servers, or whose connection can be intercepted by a man-in-the-middle.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rgqc-3x5p-6gwg
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-rgqc-3x5p-6gwg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-rgqc-3x5p-6gwg Advisory: postgres-protocol: Panic decoding a malformed `hstore` value allows denial of service IDs: GHSA-rgqc-3x5p-6gwg Record: https://patchnext.com/advisories/ghsa-rgqc-3x5p-6gwg (revision 3, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: postgres-protocol 0.6.12. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io postgres-protocol: affected < 0.6.12; fixed in 0.6.12 ## Suggested inspection (read-only) - crates.io postgres-protocol: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on postgres-protocol. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rgqc-3x5p-6gwg (OSV record GHSA-rgqc-3x5p-6gwg lists affected ranges: crates.io postgres-protocol >=0 <0.6.12 (fixed)) - Verified: https://github.com/advisories/GHSA-rgqc-3x5p-6gwg (GitHub-reviewed advisory GHSA-rgqc-3x5p-6gwg lists affected ranges: crates.io postgres-protocol >=0 <0.6.12) Commands are suggestions: review each one before running it.
Loading voting…