Critical, CVSS 9.8crates.ioPublished
lz4-sys vulnerable to memory corruption via issue in liblz4
GHSA-9q5j-jm53-v7vr
- Affected
- crates.io lz4-sys < 1.9.4
- Fixed in
- 1.9.4· Vendor fix available
- Issue
- lz4-sys up to v1.9.3 bundles a version of liblz4 that is vulnerable to CVE-2021-3520. Attackers could craft a payload that triggers an integer overflow upon decompression, causing an out-of-bounds write. The flaw has been corrected in version v1.9.4 of liblz4, which is included in lz4-sys 1.9.4.
Recommended action: Upgrade to 1.9.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.