Skip to content

← Actionable
Critical, CVSS 9.8

lz4-sys vulnerable to memory corruption via issue in liblz4

GHSA-9q5j-jm53-v7vr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lz4-sys 1.9.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io lz4-sys

    Affected
    < 1.9.4
    Fixed in
    1.9.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

lz4-sys up to v1.9.3 bundles a version of liblz4 that is vulnerable to CVE-2021-3520. Attackers could craft a payload that triggers an integer overflow upon decompression, causing an out-of-bounds write. The flaw has been corrected in version v1.9.4 of liblz4, which is included in lz4-sys 1.9.4.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9q5j-jm53-v7vr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-9q5j-jm53-v7vr

Advisory: lz4-sys vulnerable to memory corruption via issue in liblz4
IDs: GHSA-9q5j-jm53-v7vr
Record: https://patchnext.com/advisories/ghsa-9q5j-jm53-v7vr (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lz4-sys 1.9.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io lz4-sys: affected < 1.9.4; fixed in 1.9.4

## Suggested inspection (read-only)
- crates.io lz4-sys: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lz4-sys.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9q5j-jm53-v7vr (GitHub-reviewed advisory GHSA-9q5j-jm53-v7vr lists affected ranges: crates.io lz4-sys >=0 <1.9.4)

Commands are suggestions: review each one before running it.

Loading voting…