Medium, CVSS 5.1crates.ioPublished
loona-hpack Panic Vulnerability
CVE-2024-51502 · GHSA-7vm6-qwh5-9x44
- Affected
- crates.io loona-hpack <= 0.4.2
- Fixed in
- 0.4.3· Vendor fix available
- Issue
- loona-hpack suffers from the same vulnerability as the original hpack as documented in https://github.com/mlalic/hpack-rs/issues/11 Details The original includes a very nice description of the problem, as well as an easy-enough fix for it. PoC The original example pretty much still applies: Impact From the original: All users who try to decode untrusted input using the Decoder are vulnerable to this exploit. A patched version of the crate is available on crates.io under the name hpack-patched. See Cargo's documentation on overriding dependencies for more information.
Recommended action: Upgrade to 0.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.