Skip to content

← Actionable
Medium, CVSS 5.1

loona-hpack Panic Vulnerability

CVE-2024-51502GHSA-7vm6-qwh5-9x44

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (loona-hpack 0.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-51502: 0.48% estimated exploitation activity in the next 30 days; percentile 41.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary loona-hpack suffers from the same vulnerability as the original hpack as documented in https://github.com/mlalic/hpack-rs/issues/11 Details The original includes a very nice description of the problem, as well as an easy-enough fix for it. PoC The original example pretty much still applies: Impact From the original: All users who try to decode untrusted input using the Decoder are vulnerable to this exploit. A patched version of the crate is available on crates.io under the name hpack-patched. See Cargo's documentation on overriding dependencies for more information.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7vm6-qwh5-9x44

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-51502

Advisory: loona-hpack Panic Vulnerability
IDs: CVE-2024-51502, GHSA-7vm6-qwh5-9x44
Record: https://patchnext.com/advisories/cve-2024-51502 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: loona-hpack 0.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io loona-hpack: affected <= 0.4.2; fixed in 0.4.3

## Suggested inspection (read-only)
- crates.io loona-hpack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on loona-hpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7vm6-qwh5-9x44 (GitHub-reviewed advisory GHSA-7vm6-qwh5-9x44 lists affected ranges: crates.io loona-hpack >=0 <=0.4.2)

Commands are suggestions: review each one before running it.

Loading voting…