High, CVSS 7.5crates.ioPublished
Use after free in generic-array
CVE-2020-36465 · GHSA-3358-4f7f-p4j4
- Affected
- crates.io generic-array >= 0.13.0, < 0.13.3; >= 0.12.0, < 0.12.4; >= 0.11.0, < 0.11.2; >= 0.10.0, < 0.10.1; >= 0.8.0, < 0.9.1
- Fixed in
- 0.13.30.11.20.9.10.12.40.10.1· Vendor fix available
- Issue
- An issue was discovered in the generic-array crate before 0.13.3 for Rust. It violates soundness by using the arr! macro to extend lifetimes.
Recommended action: Upgrade to 0.13.3, 0.12.4, 0.11.2 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.