Use after free in generic-array
CVE-2020-36465GHSA-3358-4f7f-p4j4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (generic-array 0.13.3, 0.12.4, 0.11.2, 0.10.1, 0.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io generic-array
- Affected
- >= 0.13.0, < 0.13.3>= 0.12.0, < 0.12.4>= 0.11.0, < 0.11.2>= 0.10.0, < 0.10.1>= 0.8.0, < 0.9.1
- Fixed in
- 0.13.3, 0.11.2, 0.9.1, 0.12.4, 0.10.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3358-4f7f-p4j4 lists affected ranges: crates.io generic-array >=0.13.0 =0.12.0 =0.11.0 =0.10.0 =0.8.0 <0.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-36465: 1.27% estimated exploitation activity in the next 30 days; percentile 69.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in the generic-array crate before 0.13.3 for Rust. It violates soundness by using the arr! macro to extend lifetimes.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3358-4f7f-p4j4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-36465 Advisory: Use after free in generic-array IDs: CVE-2020-36465, GHSA-3358-4f7f-p4j4 Record: https://patchnext.com/advisories/cve-2020-36465 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: generic-array 0.13.3, 0.12.4, 0.11.2, 0.10.1, 0.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io generic-array: affected >= 0.13.0, < 0.13.3; >= 0.12.0, < 0.12.4; >= 0.11.0, < 0.11.2; >= 0.10.0, < 0.10.1; >= 0.8.0, < 0.9.1; fixed in 0.13.3, 0.11.2, 0.9.1, 0.12.4, 0.10.1 ## Suggested inspection (read-only) - crates.io generic-array: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on generic-array. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3358-4f7f-p4j4 (GitHub-reviewed advisory GHSA-3358-4f7f-p4j4 lists affected ranges: crates.io generic-array >=0.13.0 =0.12.0 =0.11.0 =0.10.0 =0.8.0 <0.9.1) Commands are suggestions: review each one before running it.
Loading voting…