Low, CVSS 3.7crates.ioPublished
CosmWasm affected by arithmetic overflows
CVE-2024-58263 · GHSA-8724-5xmm-w5xq
- Affected
- crates.io cosmwasm-std >= 1.3.0, < 1.4.4; >= 1.5.0, < 1.5.4; >= 2.0.0, < 2.0.2
- Fixed in
- 1.5.42.0.21.4.4· Vendor fix available
- Issue
- Some mathematical operations in cosmwasm-std use wrapping math instead of panicking on overflow for very big numbers. This can lead to wrong calculations in contracts that use these operations. Affected functions: - Uint{256,512}::pow / Int{256,512}::pow - Int{256,512}::neg Affected if overflow-checks = true is not set: - Uint{64,128}::pow / Int{64,128}::pow - Int{64,128}::neg
Recommended action: Upgrade to 2.0.2, 1.5.4 or 1.4.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.