Skip to content

← Actionable
Low, CVSS 3.7

CosmWasm affected by arithmetic overflows

CVE-2024-58263GHSA-8724-5xmm-w5xq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cosmwasm-std 2.0.2, 1.5.4, 1.4.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io cosmwasm-std

    Affected
    >= 1.3.0, < 1.4.4>= 1.5.0, < 1.5.4>= 2.0.0, < 2.0.2
    Fixed in
    1.5.4, 2.0.2, 1.4.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2024-58263: 0.50% estimated exploitation activity in the next 30 days; percentile 42.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Some mathematical operations in cosmwasm-std use wrapping math instead of panicking on overflow for very big numbers. This can lead to wrong calculations in contracts that use these operations. Affected functions: - Uint{256,512}::pow / Int{256,512}::pow - Int{256,512}::neg Affected if overflow-checks = true is not set: - Uint{64,128}::pow / Int{64,128}::pow - Int{64,128}::neg

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8724-5xmm-w5xq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-58263

Advisory: CosmWasm affected by arithmetic overflows
IDs: CVE-2024-58263, GHSA-8724-5xmm-w5xq
Record: https://patchnext.com/advisories/cve-2024-58263 (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cosmwasm-std 2.0.2, 1.5.4, 1.4.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io cosmwasm-std: affected >= 1.3.0, < 1.4.4; >= 1.5.0, < 1.5.4; >= 2.0.0, < 2.0.2; fixed in 1.5.4, 2.0.2, 1.4.4

## Suggested inspection (read-only)
- crates.io cosmwasm-std: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cosmwasm-std.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8724-5xmm-w5xq (GitHub-reviewed advisory GHSA-8724-5xmm-w5xq lists affected ranges: crates.io cosmwasm-std >=1.3.0 =1.5.0 =2.0.0 <2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…