Low, CVSS 2.9crates.ioPublished
buffered-reader vulnerable to out-of-bounds array access leading to panic
CVE-2023-53161 · GHSA-29mf-62xx-28jq
- Affected
- crates.io buffered-reader < 1.0.2; >= 1.1.0, < 1.1.5
- Fixed in
- 1.1.51.0.2· Vendor fix available
- Issue
- Affected versions of the crate have a bug where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.
Recommended action: Upgrade to 1.1.5 or 1.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.