buffered-reader vulnerable to out-of-bounds array access leading to panic
CVE-2023-53161GHSA-29mf-62xx-28jq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (buffered-reader 1.1.5, 1.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io buffered-reader
- Affected
- < 1.0.2>= 1.1.0, < 1.1.5
- Fixed in
- 1.1.5, 1.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-29mf-62xx-28jq lists affected ranges: crates.io buffered-reader >=0 =1.1.0 <1.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.9 · CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2023-53161: 0.39% estimated exploitation activity in the next 30 days; percentile 33.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of the crate have a bug where attacker-controlled input can result in the use of an out-of-bound array index. Rust detects the use of the out-of-bound index and causes the application to panic. An attacker may be able to use this to cause a denial-of-service. However, it is not possible for an attacker to read from or write to the application's address space.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-29mf-62xx-28jq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-53161 Advisory: buffered-reader vulnerable to out-of-bounds array access leading to panic IDs: CVE-2023-53161, GHSA-29mf-62xx-28jq Record: https://patchnext.com/advisories/cve-2023-53161 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: buffered-reader 1.1.5, 1.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io buffered-reader: affected < 1.0.2; >= 1.1.0, < 1.1.5; fixed in 1.1.5, 1.0.2 ## Suggested inspection (read-only) - crates.io buffered-reader: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on buffered-reader. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-29mf-62xx-28jq (GitHub-reviewed advisory GHSA-29mf-62xx-28jq lists affected ranges: crates.io buffered-reader >=0 =1.1.0 <1.1.5) Commands are suggestions: review each one before running it.
Loading voting…