Skip to content

← Public intelligence

crates.io package

axum-core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5crates.ioPublished

    axum-core has no default limit put on request bodies

    CVE-2022-3212 · GHSA-m77f-652q-wwp4

    Affected
    • crates.io axum-core < 0.2.8; >= 0.3.0-rc.1, <= 0.3.0-rc.1
    Fixed in
    0.2.80.3.0-rc.2· Vendor fix available
    Issue
    <bytes::Bytes as axumcore::extract::FromRequest::fromrequest would not, by default, set a limit for the size of the request body. That meant if a malicious peer would send a very large (or infinite) body your server might run out of memory and crash. This also applies to these extractors which used Bytes::fromrequest internally: - axum::extract::Form - axum::extract::Json - String The fix is also in axum-core 0.3.0.rc.2 but 0.3.0.rc.1 is vulnerable. Because axum depends on axum-core it is vulnerable as well. The vulnerable versions of axum are <= 0.5.15 and 0.6.0.rc.1. axum = 0.5.16 and = 0.6.0.rc.2 does have the fix and are not vulnerable. The patched versions will set a 2 MB limit by default.

    Recommended action: Upgrade to 0.3.0-rc.2 (pre-release) or 0.2.8 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →