axum-core has no default limit put on request bodies
CVE-2022-3212GHSA-m77f-652q-wwp4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (axum-core 0.3.0-rc.2, 0.2.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io axum-core
- Affected
- < 0.2.8>= 0.3.0-rc.1, <= 0.3.0-rc.1
- Fixed in
- 0.2.8, 0.3.0-rc.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m77f-652q-wwp4 lists affected ranges: crates.io axum-core >=0 =0.3.0-rc.1 <=0.3.0-rc.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-3212: 1.00% estimated exploitation activity in the next 30 days; percentile 62.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
<bytes::Bytes as axumcore::extract::FromRequest::fromrequest would not, by default, set a limit for the size of the request body. That meant if a malicious peer would send a very large (or infinite) body your server might run out of memory and crash. This also applies to these extractors which used Bytes::fromrequest internally: - axum::extract::Form - axum::extract::Json - String The fix is also in axum-core 0.3.0.rc.2 but 0.3.0.rc.1 is vulnerable. Because axum depends on axum-core it is vulnerable as well. The vulnerable versions of axum are <= 0.5.15 and 0.6.0.rc.1. axum = 0.5.16 and = 0.6.0.rc.2 does have the fix and are not vulnerable. The patched versions will set a 2 MB limit by default.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m77f-652q-wwp4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-3212 Advisory: axum-core has no default limit put on request bodies IDs: CVE-2022-3212, GHSA-m77f-652q-wwp4 Record: https://patchnext.com/advisories/cve-2022-3212 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: axum-core 0.3.0-rc.2, 0.2.8. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io axum-core: affected < 0.2.8; >= 0.3.0-rc.1, <= 0.3.0-rc.1; fixed in 0.2.8, 0.3.0-rc.2 ## Suggested inspection (read-only) - crates.io axum-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on axum-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m77f-652q-wwp4 (GitHub-reviewed advisory GHSA-m77f-652q-wwp4 lists affected ranges: crates.io axum-core >=0 =0.3.0-rc.1 <=0.3.0-rc.1) Commands are suggestions: review each one before running it.
Loading voting…