Skip to content

← Public intelligence

GitHub Actions package

j178/prek-action

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.9GitHub ActionsPublished

    j178/prek-action vulnerable to arbitrary code injection in composite action

    GHSA-pwf7-47c3-mfhx

    Affected
    • GitHub Actions j178/prek-action <= 1.0.5
    Fixed in
    1.0.6· Vendor fix available
    Issue
    There are three potential attacks of arbitrary code injection vulnerability in the composite action at action.yml. Details The GitHub Action variables inputs.prek-version, inputs.extraargs, and inputs.extra-args can be used to execute arbitrary code in the context of the action. PoC The previous example will print all the environment variables, and it will expose MYSECRET environment variable value to the summary of the workflow. An attacker could potentially use this vector to compromise the security of the target repository, even passing unnotice because the action will run normally. Impact Critical, CWE-94

    Recommended action: Upgrade to 1.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →