j178/prek-action vulnerable to arbitrary code injection in composite action
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (j178/prek-action 1.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
GitHub Actions j178/prek-action
- Affected
- <= 1.0.5
- Fixed in
- 1.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pwf7-47c3-mfhx lists affected ranges: GitHub Actions j178/prek-action >=0 <=1.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary There are three potential attacks of arbitrary code injection vulnerability in the composite action at action.yml. Details The GitHub Action variables inputs.prek-version, inputs.extraargs, and inputs.extra-args can be used to execute arbitrary code in the context of the action. PoC The previous example will print all the environment variables, and it will expose MYSECRET environment variable value to the summary of the workflow. An attacker could potentially use this vector to compromise the security of the target repository, even passing unnotice because the action will run normally. Impact Critical, CWE-94
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pwf7-47c3-mfhx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-pwf7-47c3-mfhx Advisory: j178/prek-action vulnerable to arbitrary code injection in composite action IDs: GHSA-pwf7-47c3-mfhx Record: https://patchnext.com/advisories/ghsa-pwf7-47c3-mfhx (revision 1, source checked 26 Oct 2026, 17:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: j178/prek-action 1.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - GitHub Actions j178/prek-action: affected <= 1.0.5; fixed in 1.0.6 ## Suggested inspection (read-only) - GitHub Actions j178/prek-action: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on j178/prek-action. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pwf7-47c3-mfhx (GitHub-reviewed advisory GHSA-pwf7-47c3-mfhx lists affected ranges: GitHub Actions j178/prek-action >=0 <=1.0.5) Commands are suggestions: review each one before running it.
Loading voting…