High, CVSS 7.3npmAmendedPublished
Prototype Pollution in y18n
CVE-2020-7774 · GHSA-c4w7-xm78-47vh
- Affected
- npm y18n < 3.2.2; >= 4.0.0, <= 4.0.0; >= 5.0.0, < 5.0.5
- Fixed in
- 3.2.25.0.54.0.1· Vendor fix available
- Issue
- The npm package y18n before versions 3.2.2, 4.0.1, and 5.0.5 is vulnerable to Prototype Pollution. POC Recommendation Upgrade to version 3.2.2, 4.0.1, 5.0.5 or later.
Recommended action: Upgrade to 5.0.5, 4.0.1 or 3.2.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Sources:osv.dev (1)github.com (2)raw.githubusercontent.com (3)nodejs.org (4)Source checked Evidence →