Skip to content

← Actionable
High, CVSS 7.3amended

Prototype Pollution in y18n

CVE-2020-7774GHSA-c4w7-xm78-47vh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (y18n 5.0.5, 4.0.1, 3.2.2; node 14.16.1, 12.22.1, 10.24.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm y18n

    Affected
    < 3.2.2>= 4.0.0, <= 4.0.0>= 5.0.0, < 5.0.5
    Fixed in
    3.2.2, 5.0.5, 4.0.1
  • runtime node

    Affected
    >= 10.0.0, < 10.24.1>= 12.0.0, < 12.22.1>= 14.0.0, < 14.16.1
    Fixed in
    10.24.1, 12.22.1, 14.16.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2020-7774: 69.59% estimated exploitation activity in the next 30 days; percentile 99.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview The npm package y18n before versions 3.2.2, 4.0.1, and 5.0.5 is vulnerable to Prototype Pollution. POC Recommendation Upgrade to version 3.2.2, 4.0.1, 5.0.5 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from vendor_advisory record nodejs-security-wg:core:78

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-c4w7-xm78-47vh

  3. Revision 1 · created ·

    Published from osv record GHSA-c4w7-xm78-47vh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-7774

Advisory: Prototype Pollution in y18n
IDs: CVE-2020-7774, GHSA-c4w7-xm78-47vh
Record: https://patchnext.com/advisories/cve-2020-7774 (revision 3, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: y18n 5.0.5, 4.0.1, 3.2.2; node 14.16.1, 12.22.1, 10.24.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm y18n: affected < 3.2.2; >= 4.0.0, <= 4.0.0; >= 5.0.0, < 5.0.5; fixed in 3.2.2, 5.0.5, 4.0.1
- runtime node: affected >= 10.0.0, < 10.24.1; >= 12.0.0, < 12.22.1; >= 14.0.0, < 14.16.1; fixed in 10.24.1, 12.22.1, 14.16.1

## Suggested inspection (read-only)
- `npm ls y18n --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- runtime node: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on y18n, node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c4w7-xm78-47vh (OSV record GHSA-c4w7-xm78-47vh lists affected ranges: npm y18n >=0 =4.0.0 =5.0.0 <5.0.5 (fixed))
- Verified: https://github.com/advisories/GHSA-c4w7-xm78-47vh (GitHub-reviewed advisory GHSA-c4w7-xm78-47vh lists affected ranges: npm y18n >=0 =4.0.0 =5.0.0 <5.0.5)
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/78.json (Node.js security working group core entry 78 lists CVE-2020-7774 affecting node >=10.0.0 =12.0.0 =14.0.0 <14.16.1)
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2020-7774 to 2021-04-06.)

Commands are suggestions: review each one before running it.

Loading voting…