Critical, CVSS 9.3npmAmendedPublished
Compromised xrpl.js versions 4.2.1, 4.2.2, 4.2.3, 4.2.4, and 2.14.2
CVE-2025-32965 · GHSA-33qr-m49q-rxfx
- Affected
- npm xrpl >= 4.2.1, < 4.2.5; >= 2.14.2, <= 2.14.2
- Fixed in
- 4.2.52.14.3· Vendor fix available
- Issue
- Impact Versions 4.2.1, 4.2.2, 4.2.3, and 4.2.4 of xrpl.js were compromised and contained malicious code designed to exfiltrate private keys. If you are using one of these versions, stop immediately and rotate any private keys or secrets used with affected systems. Version 2.14.2 is also malicious, though it is less likely to lead to exploitation as it is not compatible with other 2.x versions. Patches Upgrade to version 4.2.5 or 2.14.3. Required Actions To secure funds, think carefully about whether any keys may have been compromised by this supply chain attack, and mitigate by sending funds to secure wallets, and/or rotating keys: The XRP Ledger supports key rotation: https://xrpl.org/docs/tutorials/how-tos/manage-account-settings/assign-a-regular-key-pair If any account's master key is potentially compromised, you should disable it: https://xrpl.org/docs/tutorials/how-tos/manage-account-settings/disable-master-key-pair References…
Recommended action: Upgrade to 4.2.5 or 2.14.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.