Skip to content

← Actionable
Critical, CVSS 9.3amended

Compromised xrpl.js versions 4.2.1, 4.2.2, 4.2.3, 4.2.4, and 2.14.2

CVE-2025-32965GHSA-33qr-m49q-rxfx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xrpl 4.2.5, 2.14.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm xrpl

    Affected
    >= 4.2.1, < 4.2.5>= 2.14.2, <= 2.14.2
    Fixed in
    4.2.5, 2.14.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-32965: 0.92% estimated exploitation activity in the next 30 days; percentile 60.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Versions 4.2.1, 4.2.2, 4.2.3, and 4.2.4 of xrpl.js were compromised and contained malicious code designed to exfiltrate private keys. If you are using one of these versions, stop immediately and rotate any private keys or secrets used with affected systems. Version 2.14.2 is also malicious, though it is less likely to lead to exploitation as it is not compatible with other 2.x versions. Patches Upgrade to version 4.2.5 or 2.14.3. Required Actions To secure funds, think carefully about whether any keys may have been compromised by this supply chain attack, and mitigate by sending funds to secure wallets, and/or rotating keys: The XRP Ledger supports key rotation: https://xrpl.org/docs/tutorials/how-tos/manage-account-settings/assign-a-regular-key-pair If any account's master key is potentially compromised, you should disable it: https://xrpl.org/docs/tutorials/how-tos/manage-account-settings/disable-master-key-pair References…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-33qr-m49q-rxfx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-33qr-m49q-rxfx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-32965

Advisory: Compromised xrpl.js versions 4.2.1, 4.2.2, 4.2.3, 4.2.4, and 2.14.2
IDs: CVE-2025-32965, GHSA-33qr-m49q-rxfx
Record: https://patchnext.com/advisories/cve-2025-32965 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xrpl 4.2.5, 2.14.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm xrpl: affected >= 4.2.1, < 4.2.5; >= 2.14.2, <= 2.14.2; fixed in 4.2.5, 2.14.3

## Suggested inspection (read-only)
- `npm ls xrpl --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xrpl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-33qr-m49q-rxfx (OSV record GHSA-33qr-m49q-rxfx lists affected ranges: npm xrpl >=4.2.1 =2.14.2 <2.14.3 (fixed))
- Verified: https://github.com/advisories/GHSA-33qr-m49q-rxfx (GitHub-reviewed advisory GHSA-33qr-m49q-rxfx lists affected ranges: npm xrpl >=4.2.1 =2.14.2 <=2.14.2)

Commands are suggestions: review each one before running it.

Loading voting…