Low, CVSS 3.5npmAmendedPublished
vxe-table Cross-site Scripting vulnerability
CVE-2023-1001 · GHSA-2qjp-fg8c-g878
- Affected
- npm vxe-table < 3.7.10
- Fixed in
- 3.7.10· Vendor fix available
- Issue
- A vulnerability, which was classified as problematic, has been found in xuliangzhan vxe-table up to 3.7.9. This issue affects the function export of the file packages/textarea/src/textarea.js of the component vxe-textarea. The manipulation of the argument inputValue leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.7.10 is able to address this issue. The patch is named d70b0e089740b65a22c89c106ebc4627ac48a22d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-266123.
Recommended action: Upgrade to 3.7.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.