Skip to content

← Actionable
Low, CVSS 3.5amended

vxe-table Cross-site Scripting vulnerability

CVE-2023-1001GHSA-2qjp-fg8c-g878

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vxe-table 3.7.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2023-1001: 0.34% estimated exploitation activity in the next 30 days; percentile 28.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability, which was classified as problematic, has been found in xuliangzhan vxe-table up to 3.7.9. This issue affects the function export of the file packages/textarea/src/textarea.js of the component vxe-textarea. The manipulation of the argument inputValue leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.7.10 is able to address this issue. The patch is named d70b0e089740b65a22c89c106ebc4627ac48a22d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-266123.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2qjp-fg8c-g878

  2. Revision 1 · created ·

    Published from osv record GHSA-2qjp-fg8c-g878

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-1001

Advisory: vxe-table Cross-site Scripting vulnerability
IDs: CVE-2023-1001, GHSA-2qjp-fg8c-g878
Record: https://patchnext.com/advisories/cve-2023-1001 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vxe-table 3.7.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vxe-table: affected < 3.7.10; fixed in 3.7.10

## Suggested inspection (read-only)
- `npm ls vxe-table --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vxe-table.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2qjp-fg8c-g878 (OSV record GHSA-2qjp-fg8c-g878 lists affected ranges: npm vxe-table >=0 <3.7.10 (fixed))
- Verified: https://github.com/advisories/GHSA-2qjp-fg8c-g878 (GitHub-reviewed advisory GHSA-2qjp-fg8c-g878 lists affected ranges: npm vxe-table >=0 <3.7.10)

Commands are suggestions: review each one before running it.

Loading voting…