Skip to content

← Public intelligence

npm package

vuetify

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3npmAmendedPublished

    Vuetify has a Cross-site Scripting (XSS) vulnerability in the VDatePicker component

    CVE-2025-8082 · GHSA-9w3x-85mw-4fwm

    Affected
    • npm vuetify >= 2.0.0, < 3.0.0
    Fixed in
    3.0.0· Vendor fix available
    Issue
    Improper neutralization of the title date in the 'VDatePicker' component in Vuetify, allows unsanitized HTML to be inserted into the page. This can lead to a Cross-Site Scripting (XSS) https://owasp.org/www-community/attacks/xss attack. The vulnerability occurs because the 'title-date-format' property of the 'VDatePicker' can accept a user created function and assign its output to the 'innerHTML' property of the title element without sanitization. This issue affects Vuetify versions greater than or equal to 2.0.0 and less than 3.0.0. Note: Version 2.x of Vuetify is End-of-Life and will not receive any updates to address this issue. For more information see here https://v2.vuetifyjs.com/en/about/eol/ .

    Recommended action: Upgrade to 3.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.6npmAmendedPublished

    Vuetify has a Prototype Pollution vulnerability

    CVE-2025-8083 · GHSA-3jp5-5f8r-q2wg

    Affected
    • npm vuetify >= 2.2.0-beta.2, < 3.0.0-alpha.10
    Fixed in
    3.0.0-alpha.10· Vendor fix available
    Issue
    The Preset configuration feature of Vuetify is vulnerable to Prototype Pollution due to the internal 'mergeDeep' utility function used to merge options with defaults. Using a specially-crafted, malicious preset can result in polluting all JavaScript objects with arbitrary properties, which can further negatively affect all aspects of the application's behavior. This can lead to a wide range of security issues, including resource exhaustion/denial of service or unauthorized access to data. If the application utilizes Server-Side Rendering (SSR), this vulnerability could affect the whole server process. This issue affects Vuetify versions greater than or equal to 2.2.0-beta.2 and less than 3.0.0-alpha.10. Note: Version 2.x of Vuetify is End-of-Life and will not receive any updates to address this issue. For more information see here https://v2.vuetifyjs.com/en/about/eol/ .

    Recommended action: Upgrade to 3.0.0-alpha.10 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.4npmAmendedPublished

    Vuetify Cross-site Scripting vulnerability

    CVE-2022-25873 · GHSA-q4q5-c5cv-2p68

    Affected
    • npm vuetify >= 2.0.0-beta.4, < 2.6.10
    Fixed in
    2.6.10· Vendor fix available
    Issue
    The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.

    Recommended action: Upgrade to 2.6.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →