Skip to content

← Actionable
High, CVSS 8.6amended

Vuetify has a Prototype Pollution vulnerability

CVE-2025-8083GHSA-3jp5-5f8r-q2wg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vuetify 3.0.0-alpha.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vuetify

    Affected
    >= 2.2.0-beta.2, < 3.0.0-alpha.10
    Fixed in
    3.0.0-alpha.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
EPSS
  • CVE-2025-8083: 0.34% estimated exploitation activity in the next 30 days; percentile 27.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Preset configuration feature of Vuetify is vulnerable to Prototype Pollution due to the internal 'mergeDeep' utility function used to merge options with defaults. Using a specially-crafted, malicious preset can result in polluting all JavaScript objects with arbitrary properties, which can further negatively affect all aspects of the application's behavior. This can lead to a wide range of security issues, including resource exhaustion/denial of service or unauthorized access to data. If the application utilizes Server-Side Rendering (SSR), this vulnerability could affect the whole server process. This issue affects Vuetify versions greater than or equal to 2.2.0-beta.2 and less than 3.0.0-alpha.10. Note: Version 2.x of Vuetify is End-of-Life and will not receive any updates to address this issue. For more information see here https://v2.vuetifyjs.com/en/about/eol/ .

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3jp5-5f8r-q2wg

  2. Revision 1 · created ·

    Published from osv record GHSA-3jp5-5f8r-q2wg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-8083

Advisory: Vuetify has a Prototype Pollution vulnerability
IDs: CVE-2025-8083, GHSA-3jp5-5f8r-q2wg
Record: https://patchnext.com/advisories/cve-2025-8083 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vuetify 3.0.0-alpha.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vuetify: affected >= 2.2.0-beta.2, < 3.0.0-alpha.10; fixed in 3.0.0-alpha.10

## Suggested inspection (read-only)
- `npm ls vuetify --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vuetify.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3jp5-5f8r-q2wg (OSV record GHSA-3jp5-5f8r-q2wg lists affected ranges: npm vuetify >=2.2.0-beta.2 <3.0.0-alpha.10 (fixed))
- Verified: https://github.com/advisories/GHSA-3jp5-5f8r-q2wg (GitHub-reviewed advisory GHSA-3jp5-5f8r-q2wg lists affected ranges: npm vuetify >=2.2.0-beta.2 <3.0.0-alpha.10)

Commands are suggestions: review each one before running it.

Loading voting…