Medium, CVSS 5.3npmAmendedPublished
Outdated Static Dependency in vue-moment
GHSA-hrpp-f84w-xhfg
- Affected
- npm vue-moment < 4.1.0
- Fixed in
- 4.1.0· Vendor fix available
- Issue
- Versions of vue-moment prior to 4.1.0 contain an Outdated Static Dependency. The package depends on moment and has it loaded statically instead of as a dependency that can be updated. It has moment@2.19.1 that contains a Regular Expression Denial of Service vulnerability. Recommendation Upgrade to version 4.1.0 or later.
Recommended action: Upgrade to 4.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.