Outdated Static Dependency in vue-moment
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vue-moment 4.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vue-moment
- Affected
- < 4.1.0
- Fixed in
- 4.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hrpp-f84w-xhfg lists affected ranges: npm vue-moment >=0 <4.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hrpp-f84w-xhfg lists affected ranges: npm vue-moment >=0 <4.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of vue-moment prior to 4.1.0 contain an Outdated Static Dependency. The package depends on moment and has it loaded statically instead of as a dependency that can be updated. It has moment@2.19.1 that contains a Regular Expression Denial of Service vulnerability. Recommendation Upgrade to version 4.1.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hrpp-f84w-xhfg
- Revision 1 · created ·
Published from osv record GHSA-hrpp-f84w-xhfg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-hrpp-f84w-xhfg Advisory: Outdated Static Dependency in vue-moment IDs: GHSA-hrpp-f84w-xhfg Record: https://patchnext.com/advisories/ghsa-hrpp-f84w-xhfg (revision 2, source checked 26 Oct 2026, 12:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vue-moment 4.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vue-moment: affected < 4.1.0; fixed in 4.1.0 ## Suggested inspection (read-only) - `npm ls vue-moment --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vue-moment. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hrpp-f84w-xhfg (OSV record GHSA-hrpp-f84w-xhfg lists affected ranges: npm vue-moment >=0 <4.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-hrpp-f84w-xhfg (GitHub-reviewed advisory GHSA-hrpp-f84w-xhfg lists affected ranges: npm vue-moment >=0 <4.1.0) Commands are suggestions: review each one before running it.
Loading voting…