High, CVSS 7.5npmAmendedPublished
Uncontrolled Resource Consumption in trim-newlines
CVE-2021-33623 · GHSA-7p7h-4mm5-852v
- Affected
- npm trim-newlines < 3.0.1; >= 4.0.0, <= 4.0.0
- Fixed in
- 3.0.14.0.1· Vendor fix available
- Issue
- @rkesters/gnuplot is an easy to use node module to draw charts using gnuplot and ps2pdf. The trim-newlines package before 3.0.1 and 4.x before 4.0.1 for Node.js has an issue related to regular expression denial-of-service (ReDoS) for the .end() method.
Recommended action: Upgrade to 4.0.1 or 3.0.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.