Skip to content

← Actionable
High, CVSS 7.5amended

Uncontrolled Resource Consumption in trim-newlines

CVE-2021-33623GHSA-7p7h-4mm5-852v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trim-newlines 4.0.1, 3.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm trim-newlines

    Affected
    < 3.0.1>= 4.0.0, <= 4.0.0
    Fixed in
    3.0.1, 4.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-33623: 2.93% estimated exploitation activity in the next 30 days; percentile 87.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

@rkesters/gnuplot is an easy to use node module to draw charts using gnuplot and ps2pdf. The trim-newlines package before 3.0.1 and 4.x before 4.0.1 for Node.js has an issue related to regular expression denial-of-service (ReDoS) for the .end() method.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-7p7h-4mm5-852v

  2. Revision 1 · created ·

    Published from osv record GHSA-7p7h-4mm5-852v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-33623

Advisory: Uncontrolled Resource Consumption in trim-newlines
IDs: CVE-2021-33623, GHSA-7p7h-4mm5-852v
Record: https://patchnext.com/advisories/cve-2021-33623 (revision 2, source checked 26 Oct 2026, 12:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trim-newlines 4.0.1, 3.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm trim-newlines: affected < 3.0.1; >= 4.0.0, <= 4.0.0; fixed in 3.0.1, 4.0.1

## Suggested inspection (read-only)
- `npm ls trim-newlines --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trim-newlines.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7p7h-4mm5-852v (OSV record GHSA-7p7h-4mm5-852v lists affected ranges: npm trim-newlines >=0 =4.0.0 <4.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-7p7h-4mm5-852v (GitHub-reviewed advisory GHSA-7p7h-4mm5-852v lists affected ranges: npm trim-newlines >=0 =4.0.0 <=4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…