Skip to content

← Public intelligence

npm package

total.js

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8npmAmendedPublished

    Code Injection in total.js

    CVE-2021-23389 · GHSA-7fm6-gxqg-2pwr

    Affected
    • npm total.js < 3.4.9
    Fixed in
    3.4.9· Vendor fix available
    Issue
    The package total.js before 3.4.9 are vulnerable to Arbitrary Code Execution via the U.set() and U.get() functions.

    Recommended action: Upgrade to 3.4.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5npmAmendedPublished

    Code Injection in total.js

    CVE-2021-32831 · GHSA-vwhc-pww7-72x6

    Affected
    • npm total.js < 3.4.9
    Fixed in
    3.4.9· Vendor fix available
    Issue
    Total.js framework (npm package total.js) is a framework for Node.js platfrom written in pure JavaScript similar to PHP's Laravel or Python's Django or ASP.NET MVC. In total.js framework before version 3.4.9, calling the utils.set function with user-controlled values leads to code-injection. This can cause a variety of impacts that include arbitrary code execution. This is fixed in version 3.4.9.

    Recommended action: Upgrade to 3.4.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.8npmPublished

    total.js Remote Code Execution Vulnerability

    CVE-2021-23344 · GHSA-3wj8-vp9h-rm6m

    Affected
    • npm total.js < 3.4.8
    Fixed in
    3.4.8· Vendor fix available
    Issue
    total.js is a framework for Node.js platfrom written in pure JavaScript similar to PHP's Laravel or Python's Django or ASP.NET MVC. It can be used as web, desktop, service or IoT application. Affected versions of this package are vulnerable to Remote Code Execution (RCE) via `set`. PoC ```js // To be run in a nodejs console: require('total.js/utils').set({}, 'a;eval(`require("child_process")\\x2eexecSync("touch pwned")`);//') ```

    Recommended action: Upgrade to 3.4.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  4. High, CVSS 8.6npmAmendedPublished

    Command injection in total.js

    CVE-2020-28494 · GHSA-4449-hg37-77v8

    Affected
    • npm total.js < 3.4.7
    Fixed in
    3.4.7· Vendor fix available
    Issue
    There is a command injection vulnerability that affects the package total.js before version 3.4.7. The issue occurs in the image.pipe and image.stream functions. The type parameter is used to build the command that is then executed using childprocess.spawn. The issue occurs because childprocess.spawn is called with the option shell set to true and because the type parameter is not properly sanitized.

    Recommended action: Upgrade to 3.4.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. High, CVSS 7.3npmAmendedPublished

    Prototype pollution in total.js

    CVE-2020-28495 · GHSA-6cf8-qhqj-vjqm

    Affected
    • npm total.js < 3.4.7
    Fixed in
    3.4.7· Vendor fix available
    Issue
    There is a prototype pollution vulnerability in the package total.js before version 3.4.7. The set function can be used to set a value into the object according to the path. However the keys of the path being set are not properly sanitized, leading to a prototype pollution vulnerability. The impact depends on the application. In some cases it is possible to achieve Denial of service (DoS), Remote Code Execution or Property Injection.

    Recommended action: Upgrade to 3.4.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 6.1npmAmendedPublished

    Moderate severity vulnerability that affects total.js

    CVE-2019-10260 · GHSA-72p5-2r6g-fm6v

    Affected
    • npm total.js <= 3.3.0-12
    Fixed in
    3.3.0-13· Vendor fix available
    Issue
    Total.js CMS 12.0.0 has XSS related to themes/admin/views/index.html (item.message) and themes/admin/public/ui.js (column.format).

    Recommended action: Upgrade to 3.3.0-13 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. High, CVSS 7.5npmAmendedPublished

    Path Traversal in total.js

    CVE-2019-8903 · GHSA-3q32-j57w-q4w7

    Affected
    • npm total.js < 3.2.3
    Fixed in
    3.2.3· Vendor fix available
    Issue
    Affected versions of total.js are vulnerable to Path Traversal. Due to insufficient input sanitization in URLs, attackers can access server files outside the /public folder by using relative paths. The files served are limited to these file types: flac, jpg, jpeg, png, gif, ico, js, css, txt, xml, woff, woff2, otf, ttf, eot, svg, zip, rar, pdf, docx, xlsx, doc, xls, html, htm, appcache, manifest, map, ogv, ogg, mp4, mp3, webp, webm, swf, package, json, md, m4v, jsx, heif, heic. Recommendation - If you are using version 2.1.x, upgrade to 2.1.1 or later. - If you are using version 2.2.x, upgrade to 2.2.1 or later. - If you are using version 2.3.x, upgrade to 2.3.1 or later. - If you are using version 2.4.x, upgrade to 2.4.1 or later. - If you are using version 2.5.x, upgrade to 2.5.1 or later. - If you are using version 2.6.x, upgrade to 2.6.3 or later. - If you are using version 2.7.x, upgrade to 2.7.1 or later. - If you are using version 2.8.x, upgrade to 2.8.1 or later. - If you are…

    Recommended action: Upgrade to 3.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →