Path Traversal in total.js
CVE-2019-8903GHSA-3q32-j57w-q4w7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (total.js 3.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm total.js
- Affected
- < 3.2.3
- Fixed in
- 3.2.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3q32-j57w-q4w7 lists affected ranges: npm total.js >=0 <3.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3q32-j57w-q4w7 lists affected ranges: npm total.js >=0 <3.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2019-8903: 72.06% estimated exploitation activity in the next 30 days; percentile 99.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of total.js are vulnerable to Path Traversal. Due to insufficient input sanitization in URLs, attackers can access server files outside the /public folder by using relative paths. The files served are limited to these file types: flac, jpg, jpeg, png, gif, ico, js, css, txt, xml, woff, woff2, otf, ttf, eot, svg, zip, rar, pdf, docx, xlsx, doc, xls, html, htm, appcache, manifest, map, ogv, ogg, mp4, mp3, webp, webm, swf, package, json, md, m4v, jsx, heif, heic. Recommendation - If you are using version 2.1.x, upgrade to 2.1.1 or later. - If you are using version 2.2.x, upgrade to 2.2.1 or later. - If you are using version 2.3.x, upgrade to 2.3.1 or later. - If you are using version 2.4.x, upgrade to 2.4.1 or later. - If you are using version 2.5.x, upgrade to 2.5.1 or later. - If you are using version 2.6.x, upgrade to 2.6.3 or later. - If you are using version 2.7.x, upgrade to 2.7.1 or later. - If you are using version 2.8.x, upgrade to 2.8.1 or later. - If you are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3q32-j57w-q4w7
- Revision 1 · created ·
Published from osv record GHSA-3q32-j57w-q4w7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-8903 Advisory: Path Traversal in total.js IDs: CVE-2019-8903, GHSA-3q32-j57w-q4w7 Record: https://patchnext.com/advisories/cve-2019-8903 (revision 2, source checked 26 Oct 2026, 12:07 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: total.js 3.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm total.js: affected < 3.2.3; fixed in 3.2.3 ## Suggested inspection (read-only) - `npm ls total.js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on total.js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3q32-j57w-q4w7 (OSV record GHSA-3q32-j57w-q4w7 lists affected ranges: npm total.js >=0 <3.2.3 (fixed)) - Verified: https://github.com/advisories/GHSA-3q32-j57w-q4w7 (GitHub-reviewed advisory GHSA-3q32-j57w-q4w7 lists affected ranges: npm total.js >=0 <3.2.3) Commands are suggestions: review each one before running it.
Loading voting…