High, CVSS 7.5npmAmendedPublished
terminal-kit Inefficient Regular Expression Complexity vulnerability
CVE-2021-4306 · GHSA-wxgh-8gmr-3qh3
- Affected
- npm terminal-kit < 2.1.8
- Fixed in
- 2.1.8· Vendor fix available
- Issue
- A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 can address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.
Recommended action: Upgrade to 2.1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.