terminal-kit Inefficient Regular Expression Complexity vulnerability
CVE-2021-4306GHSA-wxgh-8gmr-3qh3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (terminal-kit 2.1.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm terminal-kit
- Affected
- < 2.1.8
- Fixed in
- 2.1.8
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wxgh-8gmr-3qh3 lists affected ranges: npm terminal-kit >=0 <2.1.8 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wxgh-8gmr-3qh3 lists affected ranges: npm terminal-kit >=0 <2.1.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-4306: 0.99% estimated exploitation activity in the next 30 days; percentile 62.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability classified as problematic has been found in cronvel terminal-kit up to 2.1.7. Affected is an unknown function. The manipulation leads to inefficient regular expression complexity. Upgrading to version 2.1.8 can address this issue. The name of the patch is a2e446cc3927b559d0281683feb9b821e83b758c. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217620.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wxgh-8gmr-3qh3
- Revision 1 · created ·
Published from osv record GHSA-wxgh-8gmr-3qh3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-4306 Advisory: terminal-kit Inefficient Regular Expression Complexity vulnerability IDs: CVE-2021-4306, GHSA-wxgh-8gmr-3qh3 Record: https://patchnext.com/advisories/cve-2021-4306 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: terminal-kit 2.1.8. A vendor fix does not mean a deployment is fixed. ## Affected components - npm terminal-kit: affected < 2.1.8; fixed in 2.1.8 ## Suggested inspection (read-only) - `npm ls terminal-kit --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on terminal-kit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wxgh-8gmr-3qh3 (OSV record GHSA-wxgh-8gmr-3qh3 lists affected ranges: npm terminal-kit >=0 <2.1.8 (fixed)) - Verified: https://github.com/advisories/GHSA-wxgh-8gmr-3qh3 (GitHub-reviewed advisory GHSA-wxgh-8gmr-3qh3 lists affected ranges: npm terminal-kit >=0 <2.1.8) Commands are suggestions: review each one before running it.
Loading voting…