Skip to content

← Public intelligence

npm package

sweetalert2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratednpmAmendedPublished

    sweetalert2 contains potentially undesirable behavior

    GHSA-mrr8-v49w-3333

    Affected
    • npm sweetalert2 >= 11.6.14, < 11.22.4
    Fixed in
    11.22.4· Vendor fix available
    Issue
    sweetalert2 versions from 11.6.14 to before 11.22.4 have potentially undesirable behavior. The package outputs audio and/or video messages that do not pertain to the functionality of the package when run on specific tlds. This functionality is documented on the project's readme.

    Recommended action: Upgrade to 11.22.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmPublished

    sweetalert2 v8.19.1 and above contains hidden functionality

    GHSA-8jh9-wqpf-q52c

    Affected
    • npm sweetalert2 >= 8.19.1, < 11.22.4
    Fixed in
    11.22.4· Vendor fix available
    Issue
    `sweetalert2` versions 8.19.1 and up until 9.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions below 8.19.1. Workaround Users who are unable to update to the fixed version (11.22.4) can use package versions 8.19.0 and below, as they do not contain the hidden functionality.

    Recommended action: Upgrade to 11.22.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  3. UnratednpmPublished

    sweetalert2 v9.17.4 and above contains hidden functionality

    GHSA-pg98-6v7f-2xfv

    Affected
    • npm sweetalert2 >= 9.17.4, < 11.22.4
    Fixed in
    11.22.4· Vendor fix available
    Issue
    `sweetalert2` versions 9.17.4 and up until 10.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 9.0.0 - 9.17.3. Workaround Users who are unable to update to the fixed version (11.22.4) can use package versions 9.0.0-9.17.3, as they do not contain the hidden functionality.

    Recommended action: Upgrade to 11.22.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  4. UnratednpmPublished

    sweetalert2 v10.16.10 and above contains hidden functionality

    GHSA-457r-cqc8-9vj9

    Affected
    • npm sweetalert2 >= 10.16.10, < 11.22.4
    Fixed in
    11.22.4· Vendor fix available
    Issue
    `sweetalert2` versions 10.16.10 and up until 11.0.0 are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 10.0.0 - 10.16.9. Workaround Use a version 10.0.0 - 10.16.9 of the package until the maintainer releases a fix.

    Recommended action: Upgrade to 11.22.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  5. UnratednpmPublished

    sweetalert2 v11.4.9 and above contains hidden functionality

    GHSA-qq6h-5g6j-q3cm

    Affected
    • npm sweetalert2 >= 11.4.9, < 11.22.4
    Fixed in
    11.22.4· Vendor fix available
    Issue
    `sweetalert2` versions 11.4.9 and above are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 11.0.0 - 11.4.8. Workaround Use a version 11.0.0 - 11.4.8 of the package until the maintainer releases a fix.

    Recommended action: Upgrade to 11.22.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →