Skip to content

← Actionable
Unrated

sweetalert2 v11.4.9 and above contains hidden functionality

GHSA-qq6h-5g6j-q3cm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sweetalert2 11.22.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm sweetalert2

    Affected
    >= 11.4.9, < 11.22.4
    Fixed in
    11.22.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

`sweetalert2` versions 11.4.9 and above are vulnerable to hidden functionality that was introduced by the maintainer. The package outputs audio and/or video messages that do not pertain to the functionality of the package and is not included in versions 11.0.0 - 11.4.8.

Workaround Use a version 11.0.0 - 11.4.8 of the package until the maintainer releases a fix.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-qq6h-5g6j-q3cm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qq6h-5g6j-q3cm

Advisory: sweetalert2 v11.4.9 and above contains hidden functionality
IDs: GHSA-qq6h-5g6j-q3cm
Record: https://patchnext.com/advisories/ghsa-qq6h-5g6j-q3cm (revision 1, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sweetalert2 11.22.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sweetalert2: affected >= 11.4.9, < 11.22.4; fixed in 11.22.4

## Suggested inspection (read-only)
- `npm ls sweetalert2 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sweetalert2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qq6h-5g6j-q3cm (OSV record GHSA-qq6h-5g6j-q3cm lists affected ranges: npm sweetalert2 >=11.4.9 <11.22.4 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…