Critical, CVSS 9.2npmAmendedPublished
survey-pdf Upgraded jsPDF Version Due to Security Vulnerability
CVE-2026-25630 · GHSA-h3q6-jfrg-3x6q
- Affected
- npm survey-pdf <= 1.12.58; >= 2.0.0, <= 2.5.4
- Fixed in
- 2.5.51.12.59· Vendor fix available
- Issue
- The following security vulnerability was identified in jsPDF versions <=3.0.4: Local File Inclusion/Path Traversal. Impact Since SurveyJS PDF Generator depends on jsPDF, any project using survey-pdf v1.12.58 and lower or v2.5.4 and lower could be exposed to this vulnerability. Solution SurveyJS PDF Generator has upgraded jsPDF to version = 4.0.0 and included the fix in the following survey-pdf releases: v1.12.59 v2.5.5 Action Users should upgrade survey-pdf in their projects to v1.12.59+ or v2.5.5+ immediately. Notes No other survey-pdf dependencies are affected. This update is fully backward-compatible with previous survey-pdf releases.
Recommended action: Upgrade to 2.5.5 or 1.12.59 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.