survey-pdf Upgraded jsPDF Version Due to Security Vulnerability
CVE-2026-25630GHSA-h3q6-jfrg-3x6q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (survey-pdf 2.5.5, 1.12.59), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm survey-pdf
- Affected
- <= 1.12.58>= 2.0.0, <= 2.5.4
- Fixed in
- 2.5.5, 1.12.59
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h3q6-jfrg-3x6q lists affected ranges: npm survey-pdf >=0 =2.0.0 <=2.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h3q6-jfrg-3x6q lists affected ranges: npm survey-pdf >=0 =2.0.0 <2.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The following security vulnerability was identified in jsPDF versions <=3.0.4: Local File Inclusion/Path Traversal. Impact Since SurveyJS PDF Generator depends on jsPDF, any project using survey-pdf v1.12.58 and lower or v2.5.4 and lower could be exposed to this vulnerability. Solution SurveyJS PDF Generator has upgraded jsPDF to version = 4.0.0 and included the fix in the following survey-pdf releases: v1.12.59 v2.5.5 Action Users should upgrade survey-pdf in their projects to v1.12.59+ or v2.5.5+ immediately. Notes No other survey-pdf dependencies are affected. This update is fully backward-compatible with previous survey-pdf releases.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-h3q6-jfrg-3x6q
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-h3q6-jfrg-3x6q
- Revision 1 · created ·
Published from ghsa record GHSA-h3q6-jfrg-3x6q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-25630 Advisory: survey-pdf Upgraded jsPDF Version Due to Security Vulnerability IDs: CVE-2026-25630, GHSA-h3q6-jfrg-3x6q Record: https://patchnext.com/advisories/cve-2026-25630 (revision 4, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: survey-pdf 2.5.5, 1.12.59. A vendor fix does not mean a deployment is fixed. ## Affected components - npm survey-pdf: affected <= 1.12.58; >= 2.0.0, <= 2.5.4; fixed in 2.5.5, 1.12.59 ## Suggested inspection (read-only) - `npm ls survey-pdf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on survey-pdf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h3q6-jfrg-3x6q (GitHub-reviewed advisory GHSA-h3q6-jfrg-3x6q lists affected ranges: npm survey-pdf >=0 =2.0.0 <=2.5.4) - Verified: https://osv.dev/vulnerability/GHSA-h3q6-jfrg-3x6q (OSV record GHSA-h3q6-jfrg-3x6q lists affected ranges: npm survey-pdf >=0 =2.0.0 <2.5.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…