Skip to content

← Public intelligence

npm package

survey-creator

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    Cross-site scripting in Survey Creator

    CVE-2024-28635 · GHSA-xgj4-2hrf-j4xg

    Affected
    • npm survey-creator < 1.9.133
    Fixed in
    1.9.133· Vendor fix available
    Issue
    Cross Site Scripting (XSS) vulnerability in SurveyJS Survey Creator v.1.9.132 and before, allows attackers to execute arbitrary code and obtain sensitive information via the title parameter in form.

    Recommended action: Upgrade to 1.9.133 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →