Cross-site scripting in Survey Creator
CVE-2024-28635GHSA-xgj4-2hrf-j4xg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (survey-creator 1.9.133), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm survey-creator
- Affected
- < 1.9.133
- Fixed in
- 1.9.133
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xgj4-2hrf-j4xg lists affected ranges: npm survey-creator >=0 <1.9.133 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xgj4-2hrf-j4xg lists affected ranges: npm survey-creator >=0 <1.9.133
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-28635: 0.51% estimated exploitation activity in the next 30 days; percentile 43.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross Site Scripting (XSS) vulnerability in SurveyJS Survey Creator v.1.9.132 and before, allows attackers to execute arbitrary code and obtain sensitive information via the title parameter in form.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xgj4-2hrf-j4xg
- Revision 1 · created ·
Published from osv record GHSA-xgj4-2hrf-j4xg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-28635 Advisory: Cross-site scripting in Survey Creator IDs: CVE-2024-28635, GHSA-xgj4-2hrf-j4xg Record: https://patchnext.com/advisories/cve-2024-28635 (revision 2, source checked 26 Oct 2026, 12:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: survey-creator 1.9.133. A vendor fix does not mean a deployment is fixed. ## Affected components - npm survey-creator: affected < 1.9.133; fixed in 1.9.133 ## Suggested inspection (read-only) - `npm ls survey-creator --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on survey-creator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xgj4-2hrf-j4xg (OSV record GHSA-xgj4-2hrf-j4xg lists affected ranges: npm survey-creator >=0 <1.9.133 (fixed)) - Verified: https://github.com/advisories/GHSA-xgj4-2hrf-j4xg (GitHub-reviewed advisory GHSA-xgj4-2hrf-j4xg lists affected ranges: npm survey-creator >=0 <1.9.133) Commands are suggestions: review each one before running it.
Loading voting…