Skip to content

← Public intelligence

npm package

ssri

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    Regular Expression Denial of Service (ReDoS)

    CVE-2021-27290 · GHSA-vx3p-948g-6vhq

    Affected
    • npm ssri >= 5.2.2, < 6.0.2; >= 7.0.0, < 7.1.1; >= 8.0.0, <= 8.0.0
    Fixed in
    7.1.18.0.16.0.2· Vendor fix available
    Issue
    npm ssri 5.2.2-6.0.1 and 7.0.0-8.0.0, processes SRIs using a regular expression which is vulnerable to a denial of service. Malicious SRIs could take an extremely long time to process, leading to denial of service. This issue only affects consumers using the strict option.

    Recommended action: Upgrade to 8.0.1, 7.1.1 or 6.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

  2. Medium, CVSS 5.9npmAmendedPublished

    Regular Expression Denial of Service in ssri

    CVE-2018-7651 · GHSA-325j-24f4-qv5x

    Affected
    • npm ssri < 5.2.2
    Fixed in
    5.2.2· Vendor fix available
    Issue
    Version of ssri prior to 5.2.2 are vulnerable to regular expression denial of service (ReDoS) when using strict mode. Recommendation Update to version 5.2.2 or later.

    Recommended action: Upgrade to 5.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →