Regular Expression Denial of Service (ReDoS)
CVE-2021-27290GHSA-vx3p-948g-6vhq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 12.22.2; ssri 8.0.1, 7.1.1, 6.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 12.0.0, < 12.22.2
- Fixed in
- 12.22.2
npm ssri
- Affected
- >= 5.2.2, < 6.0.2>= 7.0.0, < 7.1.1>= 8.0.0, <= 8.0.0
- Fixed in
- 7.1.1, 8.0.1, 6.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vx3p-948g-6vhq lists affected ranges: npm ssri >=5.2.2 =7.0.0 =8.0.0 <8.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vx3p-948g-6vhq lists affected ranges: npm ssri >=5.2.2 =7.0.0 =8.0.0 <=8.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2021-27290 to 2021-07-01.
VerifiedObserved Official nodejs.org release index (dist/index.json).
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 81 lists CVE-2021-27290 affecting node >=12.0.0 <12.22.2
VerifiedObserved Authoritative source for Node.js core CVEs: structured Node.js security-wg core vulnerability record maintained by the Node.js project.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2021-27290: 4.72% estimated exploitation activity in the next 30 days; percentile 91.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
npm ssri 5.2.2-6.0.1 and 7.0.0-8.0.0, processes SRIs using a regular expression which is vulnerable to a denial of service. Malicious SRIs could take an extremely long time to process, leading to denial of service. This issue only affects consumers using the strict option.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from vendor_advisory record nodejs-security-wg:core:81
- Revision 2 · amended ·
Amended from ghsa record GHSA-vx3p-948g-6vhq
- Revision 1 · created ·
Published from osv record GHSA-vx3p-948g-6vhq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-27290 Advisory: Regular Expression Denial of Service (ReDoS) IDs: CVE-2021-27290, GHSA-vx3p-948g-6vhq Record: https://patchnext.com/advisories/cve-2021-27290 (revision 3, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 12.22.2; ssri 8.0.1, 7.1.1, 6.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 12.0.0, < 12.22.2; fixed in 12.22.2 - npm ssri: affected >= 5.2.2, < 6.0.2; >= 7.0.0, < 7.1.1; >= 8.0.0, <= 8.0.0; fixed in 7.1.1, 8.0.1, 6.0.2 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. - `npm ls ssri --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node, ssri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vx3p-948g-6vhq (OSV record GHSA-vx3p-948g-6vhq lists affected ranges: npm ssri >=5.2.2 =7.0.0 =8.0.0 <8.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-vx3p-948g-6vhq (GitHub-reviewed advisory GHSA-vx3p-948g-6vhq lists affected ranges: npm ssri >=5.2.2 =7.0.0 =8.0.0 <=8.0.0) - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2021-27290 to 2021-07-01.) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/81.json (Node.js security working group core entry 81 lists CVE-2021-27290 affecting node >=12.0.0 <12.22.2) Commands are suggestions: review each one before running it.
Loading voting…