Skip to content

← Public intelligence

npm package

socket.io

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9npmAmendedPublished

    socket.io has an unhandled 'error' event

    CVE-2024-38355 · GHSA-25hc-qcg6-38wj

    Affected
    • npm socket.io >= 3.0.0, < 4.6.2; < 2.5.1
    Fixed in
    4.6.22.5.1· Vendor fix available
    Issue
    Impact A specially crafted Socket.IO packet can trigger an uncaught exception on the Socket.IO server, thus killing the Node.js process. Affected versions | Version range | Needs minor update? | |------------------|------------------------------------------------| | 4.6.2...latest | Nothing to do | | 3.0.0...4.6.1 | Please upgrade to socket.io@4.6.2 (at least) | | 2.3.0...2.5.0 | Please upgrade to socket.io@2.5.1 | Patches This issue is fixed by https://github.com/socketio/socket.io/commit/15af22fc22bc6030fcead322c106f07640336115, included in socket.io@4.6.2 (released in May 2023). The fix was backported in the 2.x branch today: https://github.com/socketio/socket.io/commit/d30630ba10562bf987f4d2b42440fc41a828119c Workarounds As a workaround for the affected versions of the socket.io package, you can attach a listener for the "error" event: For more information If you have any questions or comments about this advisory: - Open a discussion here Thanks a lot to Paul Taylor for the…

    Recommended action: Upgrade to 4.6.2 or 2.5.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 4.3npmAmendedPublished

    CORS misconfiguration in socket.io

    CVE-2020-28481 · GHSA-fxwf-4rqh-v8g3

    Affected
    • npm socket.io < 2.4.0
    Fixed in
    2.4.0· Vendor fix available
    Issue
    The package socket.io before 2.4.0 are vulnerable to Insecure Defaults due to CORS Misconfiguration. All domains are whitelisted by default.

    Recommended action: Upgrade to 2.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5npmAmendedPublished

    Insecure randomness in socket.io

    CVE-2017-16031 · GHSA-qv2v-m59f-v5fw

    Affected
    • npm socket.io <= 0.9.6
    Fixed in
    0.9.7· Vendor fix available
    Issue
    Affected versions of socket.io depend on Math.random() to create socket IDs, and therefore the IDs are predictable. With enough information on prior IDs, an attacker may be able to guess the socket ID and gain access to socket.io servers without authorization. Recommendation Update to v0.9.7 or later.

    Recommended action: Upgrade to 0.9.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →