Skip to content

← Actionable
Medium, CVSS 4.3amended

CORS misconfiguration in socket.io

CVE-2020-28481GHSA-fxwf-4rqh-v8g3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (socket.io 2.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2020-28481: 0.74% estimated exploitation activity in the next 30 days; percentile 54.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The package socket.io before 2.4.0 are vulnerable to Insecure Defaults due to CORS Misconfiguration. All domains are whitelisted by default.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fxwf-4rqh-v8g3

  2. Revision 1 · created ·

    Published from osv record GHSA-fxwf-4rqh-v8g3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-28481

Advisory: CORS misconfiguration in socket.io
IDs: CVE-2020-28481, GHSA-fxwf-4rqh-v8g3
Record: https://patchnext.com/advisories/cve-2020-28481 (revision 2, source checked 26 Oct 2026, 12:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: socket.io 2.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm socket.io: affected < 2.4.0; fixed in 2.4.0

## Suggested inspection (read-only)
- `npm ls socket.io --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on socket.io.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fxwf-4rqh-v8g3 (OSV record GHSA-fxwf-4rqh-v8g3 lists affected ranges: npm socket.io >=0 <2.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-fxwf-4rqh-v8g3 (GitHub-reviewed advisory GHSA-fxwf-4rqh-v8g3 lists affected ranges: npm socket.io >=0 <2.4.0)

Commands are suggestions: review each one before running it.

Loading voting…