High, CVSS 7.5npmAmendedPublished
Exposure of Sensitive Information in simple-get
CVE-2022-0355 · GHSA-wpg7-2c88-r8xv
- Affected
- npm simple-get >= 4.0.0, <= 4.0.0; >= 3.0.0, < 3.1.1; < 2.8.2
- Fixed in
- 3.1.14.0.12.8.2· Vendor fix available
- Issue
- In versions of simple-get prior to 4.0.1, 3.1.1, and 2.8.2, when fetching a remote url with a cookie location response, headers will be followed, potentially resulting in an exposure of the session cookie to a third party.
Recommended action: Upgrade to 4.0.1, 3.1.1 or 2.8.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.