Skip to content

← Actionable
High, CVSS 7.5amended

Exposure of Sensitive Information in simple-get

CVE-2022-0355GHSA-wpg7-2c88-r8xv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (simple-get 4.0.1, 3.1.1, 2.8.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm simple-get

    Affected
    >= 4.0.0, <= 4.0.0>= 3.0.0, < 3.1.1< 2.8.2
    Fixed in
    3.1.1, 4.0.1, 2.8.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-0355: 2.02% estimated exploitation activity in the next 30 days; percentile 81.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In versions of simple-get prior to 4.0.1, 3.1.1, and 2.8.2, when fetching a remote url with a cookie location response, headers will be followed, potentially resulting in an exposure of the session cookie to a third party.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wpg7-2c88-r8xv

  2. Revision 1 · created ·

    Published from osv record GHSA-wpg7-2c88-r8xv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-0355

Advisory: Exposure of Sensitive Information in simple-get
IDs: CVE-2022-0355, GHSA-wpg7-2c88-r8xv
Record: https://patchnext.com/advisories/cve-2022-0355 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: simple-get 4.0.1, 3.1.1, 2.8.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm simple-get: affected >= 4.0.0, <= 4.0.0; >= 3.0.0, < 3.1.1; < 2.8.2; fixed in 3.1.1, 4.0.1, 2.8.2

## Suggested inspection (read-only)
- `npm ls simple-get --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on simple-get.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wpg7-2c88-r8xv (OSV record GHSA-wpg7-2c88-r8xv lists affected ranges: npm simple-get >=4.0.0 =3.0.0 =0 <2.8.2 (fixed))
- Verified: https://github.com/advisories/GHSA-wpg7-2c88-r8xv (GitHub-reviewed advisory GHSA-wpg7-2c88-r8xv lists affected ranges: npm simple-get >=4.0.0 =3.0.0 =0 <2.8.2)

Commands are suggestions: review each one before running it.

Loading voting…