Skip to content

← Public intelligence

npm package

serverless

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5npmAmendedPublished

    serverless MCP Server vulnerable to Command Injection in list-projects tool

    CVE-2025-69256 · GHSA-rwc2-f344-q6w6

    Affected
    • npm serverless >= 4.29.0, < 4.29.3
    Fixed in
    4.29.3· Vendor fix available
    Issue
    A command injection vulnerability exists in the Serverless Framework's built-in MCP server package (@serverless/mcp). This vulnerability only affects users of the experimental MCP server feature (serverless mcp), which represents less than 0.1% of Serverless Framework users. The core Serverless Framework CLI and deployment functionality are not affected. The vulnerability is caused by the unsanitized use of input parameters within a call to childprocess.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, , &&, etc.). Details The MCP Server exposes several tools, including the list-project. The values of the parameter workspaceRoots (controlled by the user) is used to build a shell…

    Recommended action: Upgrade to 4.29.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →