serverless MCP Server vulnerable to Command Injection in list-projects tool
CVE-2025-69256GHSA-rwc2-f344-q6w6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (serverless 4.29.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm serverless
- Affected
- >= 4.29.0, < 4.29.3
- Fixed in
- 4.29.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rwc2-f344-q6w6 lists affected ranges: npm serverless >=4.29.0 <4.29.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rwc2-f344-q6w6 lists affected ranges: npm serverless >=4.29.0 <4.29.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-69256: 2.38% estimated exploitation activity in the next 30 days; percentile 83.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A command injection vulnerability exists in the Serverless Framework's built-in MCP server package (@serverless/mcp). This vulnerability only affects users of the experimental MCP server feature (serverless mcp), which represents less than 0.1% of Serverless Framework users. The core Serverless Framework CLI and deployment functionality are not affected. The vulnerability is caused by the unsanitized use of input parameters within a call to childprocess.exec, enabling an attacker to inject arbitrary system commands. Successful exploitation can lead to remote code execution under the server process's privileges. The server constructs and executes shell commands using unvalidated user input directly within command-line strings. This introduces the possibility of shell metacharacter injection (|, , &&, etc.). Details The MCP Server exposes several tools, including the list-project. The values of the parameter workspaceRoots (controlled by the user) is used to build a shell…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rwc2-f344-q6w6
- Revision 1 · created ·
Published from osv record GHSA-rwc2-f344-q6w6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-69256 Advisory: serverless MCP Server vulnerable to Command Injection in list-projects tool IDs: CVE-2025-69256, GHSA-rwc2-f344-q6w6 Record: https://patchnext.com/advisories/cve-2025-69256 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: serverless 4.29.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm serverless: affected >= 4.29.0, < 4.29.3; fixed in 4.29.3 ## Suggested inspection (read-only) - `npm ls serverless --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on serverless. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rwc2-f344-q6w6 (OSV record GHSA-rwc2-f344-q6w6 lists affected ranges: npm serverless >=4.29.0 <4.29.3 (fixed)) - Verified: https://github.com/advisories/GHSA-rwc2-f344-q6w6 (GitHub-reviewed advisory GHSA-rwc2-f344-q6w6 lists affected ranges: npm serverless >=4.29.0 <4.29.3) Commands are suggestions: review each one before running it.
Loading voting…