Skip to content

← Public intelligence

npm package

serve

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

9 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.3npmAmendedPublished

    vercel/serve allows access to restricted files if filename is URL encoded.

    CVE-2018-3718 · GHSA-5rc4-8qqh-vq7f

    Affected
    • npm serve < 6.5.2
    Fixed in
    6.5.2· Vendor fix available
    Issue
    serve node module suffers from Improper Handling of URL Encoding by permitting access to ignored files if a filename is URL encoded.

    Recommended action: Upgrade to 6.5.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. UnratednpmAmendedPublished

    Cross-Site Scripting in serve

    GHSA-cpgr-wmr9-qxv4

    Affected
    • npm serve < 10.0.2
    Fixed in
    10.0.2· Vendor fix available
    Issue
    Versions of serve prior to 10.0.2 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize filenames, allowing attackers to execute arbitrary JavaScript in the victim's browser through files with names containing malicious code. Recommendation Upgrade to version 10.0.2 or later.

    Recommended action: Upgrade to 10.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. UnratednpmAmendedPublished

    Cross-Site Scripting in serve

    GHSA-xw79-hhv6-578c

    Affected
    • npm serve < 10.0.2
    Fixed in
    10.0.2· Vendor fix available
    Issue
    Versions of serve prior to 10.0.2 are vulnerable to Cross-Site Scripting (XSS). The package does not encode output, allowing attackers to execute arbitrary JavaScript in the victim's browser if user-supplied input is rendered. Recommendation Upgrade to version 10.0.2 or later.

    Recommended action: Upgrade to 10.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. UnratednpmAmendedPublished

    Path Traversal in serve

    GHSA-48gc-5j93-5cfq

    Affected
    • npm serve < 10.1.2
    Fixed in
    10.1.2· Vendor fix available
    Issue
    Versions of serve prior to 10.1.2 are vulnerable to Path Traversal. Explicitly ignored folders can be accessed through relative paths, which allows attackers to access hidden folders and files. Recommendation Upgrade to version 10.1.2 or later.

    Recommended action: Upgrade to 10.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. UnratednpmAmendedPublished

    Byass due to validation before canonicalization in serve

    GHSA-wm7q-rxch-43mx

    Affected
    • npm serve < 6.5.2
    Fixed in
    6.5.2· Vendor fix available
    Issue
    Versions of serve before 6.5.2 are vulnerable to the bypass of the ignore functionality. The bypass is possible because validation happens before canonicalization of paths and filenames. Example: Here we have a server that ignores the file test.txt. Using the URL encoded form of a letter (%65 instead of e) attacker can bypass the ignore control accessing the file. curl http://localhost:1337/t%65st.txt Additionally this technique can be used to get directory listings of ignored directories. Recommendation Update to version 6.5.2 or later.

    Recommended action: Upgrade to 6.5.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. High, CVSS 7.5npmAmendedPublished

    Directory Traversal in serve

    CVE-2019-5417 · GHSA-xg75-3277-gvvj

    Affected
    • npm serve < 7.1.3
    Fixed in
    7.1.3· Vendor fix available
    Issue
    Versions of serve before 7.1.3 are vulnerable to Directory Traversal. File paths are not sanitized leading to unauthorized access of system files. Recommendation Upgrade to version 7.1.3 or later

    Recommended action: Upgrade to 7.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. High, CVSS 7.5npmAmendedPublished

    Path Traversal in serve

    CVE-2019-5415 · GHSA-v588-qcp3-jv46

    Affected
    • npm serve < 7.0.0
    Fixed in
    7.0.0· Vendor fix available
    Issue
    Versions of serve prior to 7.0.1 are vulnerable to Path Traversal. Explicitly ignored folders can be accessed through if the path contains a /./, which allows attackers to access hidden folders and files. Recommendation Upgrade to version 7.0.1 or later.

    Recommended action: Upgrade to 7.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  8. Medium, CVSS 6.5npmAmendedPublished

    Directory Traversal in serve

    CVE-2018-3712 · GHSA-q2qh-cgc2-qhr3

    Affected
    • npm serve <= 6.4.8
    Fixed in
    6.4.9· Vendor fix available
    Issue
    Affected versions of serve do not properly handle %2e (.) and %2f (/) characters, and allow the, characters to be used in paths. This can be used to traverse the directory tree and list content of any directory the user running the process has access to. Mitigating factors: This vulnerability only allows listing of directory contents and does not allow reading of arbitrary files. Recommendation Update to version 6.4.9 later.

    Recommended action: Upgrade to 6.4.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  9. Medium, CVSS 5.3npmAmendedPublished

    Information Exposure on Case Insensitive File Systems in serve

    CVE-2018-3809 · GHSA-686g-3xr3-x4x6

    Affected
    • npm serve < 7.0.0
    Fixed in
    7.0.0· Vendor fix available
    Issue
    Versions of serve before 7.0.0 are vulnerable to information exposure, bypassing the ignore security control, but only on case insensitive file systems. Recommendation Update to version 7.0.0 or later.

    Recommended action: Upgrade to 7.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →